Transactions
Resolved
Partial outage
Lasted for 14m

We've resolved the issue that impacted payments on Go and Pro readers.

Sat, Nov 18, 2023, 01:24 PM
6 months ago
Affected components
Card machines
Updates

Resolved

We've resolved the issue that impacted payments on Go and Pro readers.

Sat, Nov 18, 2023, 01:24 PM

Monitoring

We've fixed the issue that was impacting payments on Go and Pro devices and are currently monitoring the system.

Sat, Nov 18, 2023, 01:18 PM

Investigating

We've identified an issue impacting transactions on Go and Pro devices. We're currently investigating.

Sat, Nov 18, 2023, 01:10 PM