Delayed payouts
Resolved
Degraded performance
Lasted for 23h

Payouts have been processed for 15, 16 and 17 December. Payouts were delayed due to the consecutive public holidays.

Tue, Dec 19, 2023, 07:25 AM
5 months ago
Affected components
App & Portal
Updates

Resolved

Payouts have been processed for 15, 16 and 17 December. Payouts were delayed due to the consecutive public holidays.

Tue, Dec 19, 2023, 07:25 AM
20h earlier...

Identified

Please note that payouts are delayed due to the consecutive public holidays over the weekend. Please allow 1-2 days for funds to clear.

Mon, Dec 18, 2023, 11:25 AM
3h earlier...

Identified

There is a delay in payouts due to the consecutive public holidays on 15/16 Dec. We are working on getting you settled as soon as possible.

Mon, Dec 18, 2023, 07:43 AM