Revolut cards being declined for onlilne Apple Pay payments
Resolved·Degraded performance

We’ve resolved the issue that impacted Online Apple Pay transaction linked to Revolut bank cards and all our systems are stable again. Thank you for your patience while we got this fixed.

Tue, Aug 13, 2024, 02:35 PM
(8 months ago)
·
Affected components
Online payments
Updates

Resolved

We’ve resolved the issue that impacted Online Apple Pay transaction linked to Revolut bank cards and all our systems are stable again. Thank you for your patience while we got this fixed.

Tue, Aug 13, 2024, 02:35 PM

Identified

We’ve identified the cause of the issue impacting online payments with Revolut cards. We’re working on a fix with our 3rd party providers - we’ll keep you posted here.

Tue, Aug 13, 2024, 02:04 PM(31 minutes earlier)

Investigating

We’ve picked up an issue for online payments with Revolut cards, causing these payments to be declined. Our team is currently investigating - we’ll keep you posted here.

Tue, Aug 13, 2024, 01:17 PM(46 minutes earlier)