Resolved
We’ve resolved the issue preventing the sales details from displaying in the Sales History for certain bills. Thank you for your patience while we got this fixed.
Identified
We’ve identified the cause of the issue preventing the sales details from displaying in the Sales History for certain bills. We’re working on a fix - we’ll keep you posted here.
Investigating
We’ve discovered an issue in the Yoco App that prevents users from viewing sales details in the Sales History. We’re investigating and will keep you updated here.
Investigating
We’ve picked up an issue impacting you not to view specific sale details on your Sales History. Our investigation is ongoing - we’ll keep you posted here.